For this audio/video content you will need the Adobe Flash plugin (version 9 or higher), which you can download here:

Adobe Flash Plugin

After the installation, please reload the site.